';

Autor Tema: [TUTO] Tutorial par parchear el GPS y hacer ROOT los modelos MTK6589 como Nº1 S6  (Leído 27546 veces)

0 Usuarios y 1 Visitante están viendo este tema.

Desconectado pakopiwi

  • Newbie_3MSG
  • *
  • Thank You
  • -Given: 0
  • -Receive: 4
  • Mensajes: 5
  • Karma: +4/-0
    • Ver Perfil
Muchisimas gracias por tan rápida respuesta Admin.
Sí que tengo internet  ;D
Seguiré probando durante el día de hoy.

Desconectado pakopiwi

  • Newbie_3MSG
  • *
  • Thank You
  • -Given: 0
  • -Receive: 4
  • Mensajes: 5
  • Karma: +4/-0
    • Ver Perfil
Yo sigo con lo mío...
He conseguido pasar de ese punto. Ahora veo que sí que encuentra satélites, pero parece como que no enlaza.
Adjunto imagen.

Enviado desde mi JY-G4 usando Tapatalk


Desconectado Admin

  • The Boss
  • Administrator
  • Hero Member
  • *****
  • Thank You
  • -Given: 3256
  • -Receive: 8697
  • Mensajes: 13.530
  • Karma: +8711/-0
  • Sexo: Masculino
  • Dueño de tu silencio, esclavo de tus palabras
    • Ver Perfil
    • Tu Foro Tencnológico - Compras Conjuntas
¿Que quieres decir con eso de que "no enlaza"?
En qué paso estas del tutorial?

Desconectado pakopiwi

  • Newbie_3MSG
  • *
  • Thank You
  • -Given: 0
  • -Receive: 4
  • Mensajes: 5
  • Karma: +4/-0
    • Ver Perfil
He hecho todo lo del tutorial (o eso creo).
Al final del todo pone: nos salimos, damos al gps test en un lugar a cielo abierto y esperamos. Yo he usado el gps estatus (foto anterior) y espero y espero.
Donde pone Pos/Sats. no tendría que aparecer un numero que no fuera cero?
No se, estoy bastante perdido...

Enviado desde mi JY-G4 usando Tapatalk


Desconectado Admin

  • The Boss
  • Administrator
  • Hero Member
  • *****
  • Thank You
  • -Given: 3256
  • -Receive: 8697
  • Mensajes: 13.530
  • Karma: +8711/-0
  • Sexo: Masculino
  • Dueño de tu silencio, esclavo de tus palabras
    • Ver Perfil
    • Tu Foro Tencnológico - Compras Conjuntas
Has hecho lo que dice aquí?:

Citar
Si lo anterior no ha sido suficiente, y la navegación no funciona adecuadamente o los satélites no se cogen con normalidad (1-3 minutos), deberás realizar estos pasos:




        Copiamos el fichero GPS.conf en el directorio/system/etc/
        Modificamos el fichero build.prop la línea:
                                      dalvik.vm.execution-mode=int:fast
        Reiniciamosel telefono
        Ejecutamos mobileuncle tools y vamos al apartado“location” dentro del menu de ingeniero. Dentro vamos a “location Based Service”
        En la pestaña A-GPS tenemos que tener activados:
o  el A-GPS,
o  el tipo “user plane”
o  el modo “MSB”
        En la pestaña EPO activamos el “enable EPO” y“auto download”. Le damos al botón EPO para que baje el fichero.
        En la pestaña GPS activamos el GPS dando a GPS(off) y le damos a “FULL”
        Nos salimos y vamos al GPS TEST en una ubicación a cielo abierto y  esperamos…..

Desconectado pakopiwi

  • Newbie_3MSG
  • *
  • Thank You
  • -Given: 0
  • -Receive: 4
  • Mensajes: 5
  • Karma: +4/-0
    • Ver Perfil
Sí lo hice todo.
Creo que ya me funciona, aunque mañana volveré a probar para cerciorarme.
Tuve un error de novato.
Resulta que desde jiayu.es me bajé un zip con 3 archivos que supuestamente mejoraban el gps si los cambiabas por los que ya venían en la ROM. Pues bien, yo los descomprimí a la vez y en lugar de hacerlo en System/etc quedaron en System/etc/GPS sin que me diera cuenta.

He salido a correr después de repetir los pasos del tutorial unas 15 veces y cuando llevaba unos 5 min de carrera ha empezado a registrar la señal el runkeeper asiq es buena señal ;).

Por cierto!! No se os ocurra cambiar los permisos del archivo build.prop
Yo lo hice por probar (a la desesperada) y no me arrancaba el Movil. A tirar de Recovery para instalar ROM.

Para terminar, os doy nuevamente las gracias. Hacéis una gran labor y es de agradecer.
Un saludo.

Desconectado nuevohere

  • Newbie_1MSG
  • *
  • Thank You
  • -Given: 0
  • -Receive: 0
  • Mensajes: 2
  • Karma: +0/-0
    • Ver Perfil
Buenas, os comento mi problema a ver si me echais una mano y lo puedo solucionar. Yo tengo un jiayu g3sturbo (version de android 4.2.1), y despues de seguir todos los pasos del tutorial consigo fijar los satelites y en ese mismo instante el gps funciona correctamente. Pero despues de un rato cuando vuelvo a abrir cualquier aplicacion que utilice el gps ya no me localiza la ubicacion (por ejemplo google maps) o en otras aplicaciones me marca la ubicacion donde fije los satelites.
Si quiero volver a utilizar google maps por ejemplo tengo que volver a localizar los satelites y entonces si que me marca la ubicacion de nuevo.
Como puedo hacer para no tener que repetir el proceso de fijar los satelites cada vez que quiera utilizar una aplicacion que demande el gps?

Gracias de antemano y lo siento por las tildes pero estoy escribiendo desde un teclado ingles.

Desconectado Admin

  • The Boss
  • Administrator
  • Hero Member
  • *****
  • Thank You
  • -Given: 3256
  • -Receive: 8697
  • Mensajes: 13.530
  • Karma: +8711/-0
  • Sexo: Masculino
  • Dueño de tu silencio, esclavo de tus palabras
    • Ver Perfil
    • Tu Foro Tencnológico - Compras Conjuntas
Hola nuevohere. En teoría se debería solucionar con la segunda parte del tuto que precisamente dice de hacerlo si los pasos anteriores no han sido suficientes.
Si no se soluciona lo mejor es comenzar de cero con una instalación limpia (nueva ROM o restaurar datos de fabrica)

Desconectado nuevohere

  • Newbie_1MSG
  • *
  • Thank You
  • -Given: 0
  • -Receive: 0
  • Mensajes: 2
  • Karma: +0/-0
    • Ver Perfil
Muchas gracias por la rápida respuesta. ¿Es la única solución restablecer datos de fábrica o instalar una nueva room?
El segundo paso del tutorial también lo he hecho y sigue pasando lo mismo cada vez que quiero utilizar el gps tengo que volver a fijar los satélites, no tardan nada en fijarse un minuto o poco más pero es un fastidio tener que hacerlo cada vez.

El móvil me acaba de llegar de fábrica después de mandarlo a reparar por problemas de la placa base (sólo tiene tres meses), antes no tenía tantos problemas con el gps y no me gustaría cambiar de room si hay una solución alternativa...


Desconectado mikidomi

  • Newbie_1MSG
  • *
  • Thank You
  • -Given: 0
  • -Receive: 0
  • Mensajes: 2
  • Karma: +0/-0
    • Ver Perfil
Yo he hecho el paso 1 y soy root.
Luego he hecho todo lo que se dice para activar el gps y no me funciona.
no existe la linea
dalvik.vm.execution-mode=int:fast
por ningun lado y se la he añadido al final del archivo.
he seguido todos los pasos y ve 10 satelites, pero me puedo llevar con el gps test hasta mañana que no usa ninguno.
Qué mas pedo hacer?
AYUDA
« última modificación: Mayo 30, 2014, 20:00:25 pm por mikidomi »

Desconectado erratico14

  • Colaboradores
  • Hero Member
  • *
  • Thank You
  • -Given: 5284
  • -Receive: 2655
  • Mensajes: 3.920
  • Karma: +2693/-0
  • Sexo: Masculino
    • Ver Perfil
Hola mikidomi,
Conoces la aplicación MobileUncle Mtk Tools?
Porque si ya eres root, hay una linea en la portada cuando la abres, que dice algo así: "Liberar bloqueo Gprs del operador"
Pincha ahí, y luego dale a activar Gprs.
Y luego justo debajo de esa, pincha en "Mejora la búsqueda GPS" dale a Seleccionar GPS, deja que actue.

Mejora bastante y tardas unos segundos en hacerlo.

Cuéntanos si te ha funcionado, ok?
« última modificación: Mayo 31, 2014, 00:54:15 am por erratico14 »
No te quedes sin tu Xiaomi Mi5. Apúntate aquí:  http://forotek.net/index.php?topic=36883.0

Desconectado mikidomi

  • Newbie_1MSG
  • *
  • Thank You
  • -Given: 0
  • -Receive: 0
  • Mensajes: 2
  • Karma: +0/-0
    • Ver Perfil
Hola erratico14, he hecho lo que me has dicho y sigo igual. Pongo el gps test y veo 8 o 9 satélites pero no se conecta a ninguno. Estoy por ponerle una ROOM nueva para este modelo, pero no me fio, me da miedo cargarme todo.
No se que hacer.

Desconectado erratico14

  • Colaboradores
  • Hero Member
  • *
  • Thank You
  • -Given: 5284
  • -Receive: 2655
  • Mensajes: 3.920
  • Karma: +2693/-0
  • Sexo: Masculino
    • Ver Perfil
Yo lo tuve una buena temporada y haciendo eso que te decía me conectaba bastante bien, de hecho hice algunos viajes en coche a sitios que no conocía y me llevó sin ningún problema.
Lo que no sé decirte es que rom montaba el mío. Ya no lo tengo.  :-\
Si te atreves, prueba a cambiar la rom,  y meter alguna que tengan mejorado el Gps, que por defecto lo suelen hacer los cocineros.
Ánimo y mucha suerte, compañero.
No te quedes sin tu Xiaomi Mi5. Apúntate aquí:  http://forotek.net/index.php?topic=36883.0

Desconectado edup21

  • Newbie_1MSG
  • *
  • Thank You
  • -Given: 0
  • -Receive: 0
  • Mensajes: 1
  • Karma: +0/-0
    • Ver Perfil
Tengo en cubot gt 99 y he hecho esto y no me funciona puede que sea el contacto con la antena que este en mal estado?

Desconectado thejulk

  • Colaboradores
  • Hero Member
  • *
  • Thank You
  • -Given: 8560
  • -Receive: 648
  • Mensajes: 697
  • Karma: +648/-0
  • Sexo: Masculino
    • Ver Perfil
Tengo en cubot gt 99 y he hecho esto y no me funciona puede que sea el contacto con la antena que este en mal estado?
Si tienes una operadora  virtual, asegurate de que en la configuración del Agps tengas activado que se actualice por intinerancia de datos, sino no coges satélites ni de coña.
Saludos
"Yo he visto cosas que vosotros no creeríais. Atacar naves en llamas más allá de Orión. He visto Rayos-C brillar en la oscuridad cerca de la Puerta de Tannhäuser. Todos esos momentos no se perderán en el tiempo como lágrimas en la lluvia. Es hora de... ForoTek"

Desconectado Francisco

  • Newbie_3MSG
  • *
  • Thank You
  • -Given: 0
  • -Receive: 2
  • Mensajes: 17
  • Karma: +2/-1
    • Ver Perfil
Efectivamente vale para todos

Utiliza nuestro Localizador de Envíos para saber donde está tu paquete
__

 


         
Twittear